- Проблем с превод на .po файл с PoEdit за тема на Wordpress
WT форуми -> CMS -> Проблем с превод на .po файл с PoEdit за тема на Wordpress
Създайте нова тема Напишете отговор 
Автор Съобщение
vinsbg
Редовен
Редовен

Регистриран на: 28/01/2009 2:21 pm

Support: 51
Bonus: 87
Мнения: 2587
Мнение 08/05/2014 10:32 am     Проблем с превод на .po файл с PoEdit за тема на Wordpress Отговорете с цитат


Здравейте,
пиша тук, защото не знам къде точно да я постна тази тема Smile

Та проблема, е че инсталирах една тема на един Wordpress. Темата е с .po и .mo файлове за езика. Свалих английския .po на локалния хост, преведох си каквото ми трябваше, но след като го качих на самия сайт не иска да смени с превода.

Когато отворя .po файла от хоста си изглежда нормално. Какво може да е?
Не съм превеждал до сега с така с .po файлове и не съм много наясно, защо се получава така...

Благодаря!
Върнете се в началото
Вижте профила на потребителя Изпратете лично съобщение Посетете сайта на потребителя
Hous
Активен
Активен

Регистриран на: 22/03/2008 11:19 pm

Support: 111
Bonus: 213
Мнения: 2538
Мнение 08/05/2014 10:43 pm      Отговорете с цитат


Името на файла най-вероятно... гледай да не променяш шаблона:
myfile_en.po
myfile_en.mo

понякога смаия превод е примерно bg.po
вместо
myfile_bg.po

Освен това, друга вероятна причина не съм сигурен защото не знам какво точно си превел и как. Smile
Върнете се в началото
Вижте профила на потребителя Изпратете лично съобщение
vinsbg
Редовен
Редовен

Регистриран на: 28/01/2009 2:21 pm

Support: 51
Bonus: 87
Мнения: 2587
Мнение 09/05/2014 7:45 am      Отговорете с цитат


Файловете са:
en-US.mo
en-US.po

Когато отворя .po файла виждам това
Цитат:
#: C:\Users\andrei\Desktop\themes\Theme/functions.php:1971
msgid "Yes"
msgstr ""

Когато с PoEditora преведа това 'Yes' на 'Да', този същия ред във файла става така
Цитат:

#: C:\Users\andrei\Desktop\themes\Theme/functions.php:1971
msgid "Yes"
msgstr "Да"


После си качвам нормално новите .po и .mo файлове на хоста. Не би ли трябвало вече вместо Yes да се визуализира Да?

Освен това нямам представа, какво е това #: C:\Users\andrei\Desktop\themes\... това не е моя юзър на моя компютър Smile
Върнете се в началото
Вижте профила на потребителя Изпратете лично съобщение Посетете сайта на потребителя
Hous
Активен
Активен

Регистриран на: 22/03/2008 11:19 pm

Support: 111
Bonus: 213
Мнения: 2538
Мнение 11/05/2014 9:13 pm      Отговорете с цитат


Имената на файловете които качваш как са?
Иначе това е пътя към файла когато е създавана темата.
Върнете се в началото
Вижте профила на потребителя Изпратете лично съобщение
vinsbg
Редовен
Редовен

Регистриран на: 28/01/2009 2:21 pm

Support: 51
Bonus: 87
Мнения: 2587
Мнение 12/05/2014 6:57 am      Отговорете с цитат


Hous написа:
Имената на файловете които качваш как са?
Иначе това е пътя към файла когато е създавана темата.

Имената на файловете не ги променям... каквито са били, когато ги свалям и качвам имената не ги свалям.
Върнете се в началото
Вижте профила на потребителя Изпратете лично съобщение Посетете сайта на потребителя
Hous
Активен
Активен

Регистриран на: 22/03/2008 11:19 pm

Support: 111
Bonus: 213
Мнения: 2538
Мнение 12/05/2014 4:10 pm      Отговорете с цитат


Идеята ми е че ако превеждаш примерно файлове:
en_EN.po
en_EN.mo
трябва българските файлове да са съответно
bg_BG.po
bg_BG.mo
Върнете се в началото
Вижте профила на потребителя Изпратете лично съобщение
vinsbg
Редовен
Редовен

Регистриран на: 28/01/2009 2:21 pm

Support: 51
Bonus: 87
Мнения: 2587
Мнение 12/05/2014 6:31 pm      Отговорете с цитат


Hous написа:
Идеята ми е че ако превеждаш примерно файлове:
en_EN.po
en_EN.mo
трябва българските файлове да са съответно
bg_BG.po
bg_BG.mo

Боже.. за това пък не се сетих. Така стана, да. Благодаря Question
Върнете се в началото
Вижте профила на потребителя Изпратете лично съобщение Посетете сайта на потребителя
Pole
Нов
Нов

Регистриран на: 20/01/2015 8:04 pm

Support: 0
Bonus: 0
Мнения: 1
Мнение 20/01/2015 8:16 pm      Отговорете с цитат


Аз имам същия проблем Sad
Имам тема превеждам файла, получават се нови .mo и .po слагам ги в localization папката и не се превежда. Чета тук там и се променя един ред в function.php, но при мен този ред го няма.
Моля за помощ
Върнете се в началото
Вижте профила на потребителя Изпратете лично съобщение Изпрати мейла
Покажи мнения от преди:    
Създайте нова тема   Напишете отговор    web-tourist.net Форуми -> CMS Часовете са според зоната GMT + 2 Часа
Страница 1 от 1


 
Идете на:  
Не Можете да пускате нови теми
Не Можете да отговаряте на темите
Не Можете да променяте съобщенията си
Не Можете да изтривате съобщенията си
Не Можете да гласувате в анкети