Проблем, при края на регистрацията!

Проблеми, въпроси, модове и темплейти.
Post Reply
User avatar
pepo13
Нов
Нов
Posts: 131
Joined: Mon Jan 08, 2007 8:36 pm
Contact:

Проблем, при края на регистрацията!

Post by pepo13 » Tue Jan 09, 2007 8:46 pm

Значи проблема ми е следния, след като се регистрира някои, на края на регистрацията(Когато завъпшва) Место да пише нещо от рода "Регистрирахте се успешно" ми пише това :

Code: Select all


Failed sending email :: PHP :: 

DEBUG MODE

Line : 234
File : emailer.php

Моля за помощ, как да махна този проблем ?

User avatar
Rex
Турист
Турист
Posts: 223
Joined: Tue Jan 09, 2007 8:41 pm

Post by Rex » Tue Jan 09, 2007 9:02 pm

на мен ми изписва същото, но и като изпращам ЛС :cry:

User avatar
LiRiX
Шаман
Шаман
Posts: 4330
Joined: Fri Mar 31, 2006 8:52 am
Answers: 165
Location: Търговище

Post by LiRiX » Tue Jan 09, 2007 9:05 pm

Изтрии 234 ред в emailer.php

User avatar
Rex
Турист
Турист
Posts: 223
Joined: Tue Jan 09, 2007 8:41 pm

Post by Rex » Tue Jan 09, 2007 9:09 pm

едвали това е правилното решение.. аз съм мислил грешката да я запиша нещо като поздравително съобщение

User avatar
mizarck
Гуру
Гуру
Posts: 2195
Joined: Fri May 05, 2006 7:51 pm
Answers: 39
Location: София

Post by mizarck » Tue Jan 09, 2007 9:14 pm

Rex wrote:едвали това е правилното решение.. аз съм мислил грешката да я запиша нещо като поздравително съобщение

тови има такова сообщение
но просто първо изкарва грешката ако изтриеш ред 234 от emailer.php вместо грешката ще се изписва
БЛАГОДАРЯ ВИ ЧЕ СЕ РЕГИСТРИРАХТЕ......

Pr0oF
Турист
Турист
Posts: 565
Joined: Sat Jun 10, 2006 8:48 pm
Answers: 38

Post by Pr0oF » Tue Jan 09, 2007 9:43 pm

Нямаш подръжка на SMTP сървър, затова ти изписва грешката.
Дефакто грешка има, но потребителя пак се регистрира.
Ако някой желае да ти потърси кода в дата.бг там дадаха как се управя, ако не утре като се прибера ще ти го дам.

User avatar
iwanov
Шаман
Шаман
Posts: 3045
Joined: Wed Nov 01, 2006 9:18 pm
Answers: 192
Location: Варна

Post by iwanov » Tue Jan 09, 2007 10:08 pm

За да премахнете това съобщение отивате в директорията на форума в папка \includes\ и намирате файла emailer.php.

Трябва да откриете и премахнете следните редове от него:
if (!$result)
{
message_die(GENERAL_ERROR, 'Failed sending email :: ' . (($this->use_smtp) ? 'SMTP' : 'PHP') . ' :: ' . $result, '', __LINE__, __FILE__);
}

Това го копирах от уроците които са в тоя сайт.На 100% си работи (поне при мен)

User avatar
Rex
Турист
Турист
Posts: 223
Joined: Tue Jan 09, 2007 8:41 pm

Post by Rex » Tue Jan 09, 2007 10:37 pm

аз бях дръпнал някакав си QK SMTPT Server ама нещо неможах да го подкарам.. уж работи но пак не мога да изпращам email-и.. бе и конфигурацията неразбрах как се прави.. няможах да намеря урок за него..
/едит:

и Да, махнах тези редове и стана ! мерси :)

но все пак искам да си оправя smtp-то

User avatar
pepo13
Нов
Нов
Posts: 131
Joined: Mon Jan 08, 2007 8:36 pm
Contact:

Post by pepo13 » Wed Jan 10, 2007 10:51 am

Бладгодаря, стана ;)

Post Reply