Проблем с един таг

Post Reply
User avatar
The_Chief
Нов
Нов
Posts: 38
Joined: Mon May 29, 2006 4:51 pm

Проблем с един таг

Post by The_Chief » Mon Jun 26, 2006 7:36 pm

Проблемът ми е следният - направил съм си рамка на главната страница като съм използвал таготете <FRAMESET>. До както знам тагът TARGET оказва къде точно да се отваря избраната препратка например. Е да но не става. Като щракна върху нея се товаря в същото поле, не в това дето съм задал. Моля ако някои знае нещо по въпроса да помогне. Благодаря Ви предварително.

Admin
Site Admin
Site Admin
Posts: 4
Joined: Thu Jan 01, 1970 12:00 am
Answers: 224

Post by Admin » Mon Jun 26, 2006 8:34 pm

Дай малко код. :)
Че така ми е трудно.

Иначе си прав.
Така както казваш е правилно.

Трябва всеки фрейм да си има име.
Да е зададено как се назва.
< frame name="frame1">

После линка трябва да е нещо от сорта на:
<a href="dada.html" target="frame1">

User avatar
mute
Шаман
Шаман
Posts: 3127
Joined: Sun Sep 25, 2005 10:14 pm
Answers: 167
Location: between mind & heart
Contact:

Post by mute » Mon Jun 26, 2006 8:36 pm

е би трябвало да става като зададеш target="name"
name е името на фреима ако искаш качи някаде саита и даи линк да видим

User avatar
The_Chief
Нов
Нов
Posts: 38
Joined: Mon May 29, 2006 4:51 pm

Post by The_Chief » Tue Jun 27, 2006 5:42 pm

Eто и конкретния проблем:
<html>
<head>
<title>Kystendil</title>
</head>
<frameset rows="123,*" border="5">
<frame name="kyustendil" noresize src="kyustendil.html">
<frameset cols="172,*" border="5">
<frame name="main" noresize src="main.html" target="home">
<frame name="home" noresize src="home.html">
</frameset>
<frameset>
</html>

и другата страница:
<html>
<head>
<title>main</title>
</head>
<body background="tex9.jpg">
<font size=6><center>Азбучник</center></font>
<br><font size=8><a href="http://kystendil.hit.bg/a.html"><center ... </a></font>
</body>
</html>
като си кликна на "А" то се отваря в Main, a не в Home
Аз не разбирам много но мисля че нещата са така но все пак не се получава. Моля помогнете

User avatar
The_Chief
Нов
Нов
Posts: 38
Joined: Mon May 29, 2006 4:51 pm

Post by The_Chief » Tue Jun 27, 2006 5:53 pm

Да разбрах си грешката - не знаех че трябва да сложа и таргет и на самия линк. Благодаря ти админе за краткия пример :D

Post Reply