Бавен сайт

Search Engine Optimization. Оптимизиране, популяризиране и позициониране на сайт за търсачки.
User avatar
PHPnMySQL
Нов
Нов
Posts: 197
Joined: Wed Feb 20, 2008 10:47 pm
Location: Megapolis Sofia City
Contact:

Бавен сайт

Post by PHPnMySQL » Tue Sep 27, 2016 6:51 pm

Здравейте, имам сайт на уърдпрес с платена тема от themeforest. Напоследък темата се бави доста при първоначалното си зареждане, преди не беше така.При повторно зареждане си излиза нормално. Кореспондирах си с хората от хостинга, те казаха,че няма абсолютно никакви проблеми от тяхна страна(суперхостинг), като тестваха 3 пъти и 3 пъти казаха,че всичко е точно при тях. Писах си със съпорта на темата, те въртяха, сукаха, но в крайна сметка казах,че не би трябвало проблема да е от темата, защото нищо не е променяна по нея. Инсталираха ми плъгин "autoptimize" , което накара сайта да зарежда първоначално от 10 секунди до 15 секунди. Дейнсталирах го, падна на 10 секунди отново. Инсталирах SuperCache плъгин, никакъв ефект. Сайта е www.fotografia.bg ,всички снимки по него са оразмерени за интернет употреба, целия сайт мисля, че е около 33мб. Проблема не идва от плъгининте, изключвах ги един по един, но не даде резултат, същото е. Предложения ?


ПС Това не е реклама на сайта, наистина имам проблем!

novakabg
Турист
Турист
Posts: 337
Joined: Fri May 13, 2016 12:29 pm
Contact:

Post by novakabg » Wed Sep 28, 2016 6:07 am

Ползвай : https://gtmetrix.com

Нямаш:
- Gzip compression
- Browser caching
- Minify JavaScript

Нямаш и Optimize images но за този вид сайт не трябва да правиш никакви оптимизации на снимките :)

User avatar
PHPnMySQL
Нов
Нов
Posts: 197
Joined: Wed Feb 20, 2008 10:47 pm
Location: Megapolis Sofia City
Contact:

Post by PHPnMySQL » Wed Sep 28, 2016 8:00 am

Благодаря! Как да оправя гореспоменатите неща ?


User avatar
PHPnMySQL
Нов
Нов
Posts: 197
Joined: Wed Feb 20, 2008 10:47 pm
Location: Megapolis Sofia City
Contact:

Post by PHPnMySQL » Wed Sep 28, 2016 9:32 am

Значи! Инсталирах плъгините 1. Fast Velocity Minify и 2. WP SMASH , вкарах два кода в hcacces и намалихме скоростта от 15.5сек до 7сек според GTMatrix, ала не иска още, не знам какво да направя още

novakabg
Турист
Турист
Posts: 337
Joined: Fri May 13, 2016 12:29 pm
Contact:

Post by novakabg » Wed Sep 28, 2016 6:50 pm

Гледам си намерил човек който да ти оправи сайта радвам се :)

User avatar
dakata__92
Шаман
Шаман
Posts: 3159
Joined: Tue Aug 02, 2011 7:24 pm
Answers: 124

Post by dakata__92 » Wed Sep 28, 2016 7:05 pm

Пробвай с Minify на изходният код. Ще спечели някой друга секунда при зареждане, но просто при отпечатване на снимките нещата си стават бавно.

User avatar
PHPnMySQL
Нов
Нов
Posts: 197
Joined: Wed Feb 20, 2008 10:47 pm
Location: Megapolis Sofia City
Contact:

Post by PHPnMySQL » Wed Sep 28, 2016 7:45 pm

Ами оказа се, че е сравнително просто. Смених началната страница да е някоя, която е текст и малко снимки, а не портфолиото, където се очаква страницата да е бъкана със снимки с високо качество. Сайта е в процес на регистрация към CloudFlare за да ми се подобрят и CDN.

Не мога да разбера само защо от GTMetrix все още ми показва, че снимките не са оразмерени, при положение, че всичките минаха през компресия(от което ме заболя сърцето) на SMUSH плъгина ?

Все пак свалихме сайта от 15сек на 3сек, което е огромна разлика! Благодаря!

User avatar
PHPnMySQL
Нов
Нов
Posts: 197
Joined: Wed Feb 20, 2008 10:47 pm
Location: Megapolis Sofia City
Contact:

Update!

Post by PHPnMySQL » Mon Nov 07, 2016 2:09 pm

Здравейте! В крайна сметка след много манипулации сайта действа доста по-добре, но отново неоправдано бавен! Ето какво съм направил до момента:
1. Преинсталирах уърдпрес и всичко наново.
2. Върнаха ми парите за темата, купих нова тема
3. Закупих WP Rocket кешинг плъгин, пуснах минифай на всичко, като това не засяга интерфейса на сайта, също така обединих JS и CSS в едни файлове, така че да не прави по 15 HTTP рекуеста
4. Снимките са оптимизирани.


В прикачения файл ще видите, че сайта би трябвало да зарежда за около 2 секунди според GTMetrix, но не разбирам след зареждането на всичко има една дъъъълга линия на празно пространство, която не мога да си обясня, но тя гълта всичко. Някой ако може да даде обяснение от къде идва проблема?

Image

User avatar
vinsbg
Гуру
Гуру
Posts: 2604
Joined: Wed Jan 28, 2009 12:21 pm
Answers: 51
Location: София
Contact:

Post by vinsbg » Tue Nov 08, 2016 4:36 am

Не знам, но при мен си зарежда за 1.5-2.2 секунди.. като най-много време ~1.2 секунда отнемат снимките.

Post Reply