Налазиха ме секс ботове

Статус
Not open for further replies.

Admin

Registered
Яко ме налазиха.
Вече имам едно постче с секс линкове и 10 user-a със
секс сайтове в профила си.
Версията на форума е стара но ако почна да я ъпдейтвам ще си създам много работа.
Написах едно модче.
Незнам дали ще спаси работата но ще го постна за да пробвате и вие.
Най вероятно има готов мод за тази цел но нямам време да търся.

Проблема е, че не се генерира картинка :) ама кой му пука.
Надявам се, че ботовете са тъпички.

Ето какво направих:

Слагам тази картинка в директорията /images/ .

После oтварям файла /темплейта/profil_add_body.tpl и намирам следния код:

Код:

Преди него пиша следното:
Код:
	<tr> 
	  <td class="row1" colspan="2"><span class="gen"><center><img src="images/reg.gif"></center></span>
	  </td>
	</tr>
	<tr> 
	  <td class="row1"><span class="gen">Въведете кода: *</span><br />
		<span class="gensmall"></span></td>
	  <td class="row2"> 
		<input type="text" class="post" style="width: 200px" name="bot" size="25" maxlength="32" value="" />
	  </td>
	</tr>

После отварям файла includes/usercp_register.php и намирам следните редове (в началото):
Код:
if ( !defined('IN_PHPBB') )
{
	die("Hacking attempt");
	exit;
}

след него пиша следното:

Код:
$botstop=$HTTP_POST_VARS['bot'];

после намирам следните редове:


Код:
		else if ( strlen($new_password) > 32 )
		{
			$error = TRUE;
			$error_msg .= ( ( isset($error_msg) ) ? '<br />' : '' ) . $lang['Password_long'];
		}

под тях пиша следното:


Код:
		else if (empty ($botstop))
		{
			$error = TRUE;
			$error_msg .= ( ( isset($error_msg) ) ? '<br />' : '' ) . '<font color="ff0000"><b>Не сте въвели кода от картинката</b></font>';
		}
		else if ( $botstop != "HVAGDK" )
		{
			$error = TRUE;
			$error_msg .= ( ( isset($error_msg) ) ? '<br />' : '' ) . '<font color="ff0000"><b>Не сте въвели правилно кода от картинката</b></font>';
		}


Записвам.
При регистрацията трябва да въведе кода от картинката.
Този код не се променя ама се надявам, че няма как да разбере.



Ако някой има същия проблем може да пробва с този мод.
 
Ако не се генерира картинка можеш да сложиш около десет картинки и когато се дава рефлеш да се сменят някъде в форума има такъв js.
 
staf каза:
Ако не се генерира картинка можеш да сложиш около десет картинки и когато се дава рефлеш да се сменят някъде в форума има такъв js.

Няма нужда мисля.
Просто няма да могат да се регват автоматично.
 
ъъ.. случва ми с в форума, някъф с някво име (нз кво беше, от рода на "hadafasdasas" ) пускаше разни секс линкове и аз всеки път ги делкам де :shock:

Баннах ай-пи-то.. :roll:
 
NetCutter каза:
еми и това е решение,ама не пълно :wink:
Почнаха пак да се регват такива юзъри с някви имена от сорта "афавадсг" и сложих онуй с картинката, при регистрация да сложеш кода :)
 
Сайта ги засича.
По 10 на ден се опитват да се регнат.
От различни ИП адреси и различни пощи.

ТОва обаче ги спира.
 
Опитах се да го направя това с кода ,ама
ми дава грешка при опит да добавя това

else if (empty ($botstop))
{
$error = TRUE;
$error_msg .= ( ( isset($error_msg) ) ? '<br />' : '' ) . '<font color="ff0000"><b>Не сте въвели кода от картинката</b></font>';
}
else if ( $botstop != "HVAGDK" )
{
$error = TRUE;
$error_msg .= ( ( isset($error_msg) ) ? '<br />' : '' ) . '<font color="ff0000"><b>Не сте въвели правилно кода от картинката</b></font>';
}


Изписва :
Parse error: parse error, unexpected T_ELSE in /home/fhhost/public_html/fcinter/includes/usercp_register.php on line 332


Може да е странен проблема щото windows-а ми е доста бъгнат и трябваше да сменям туй на кирилица със латиница
:wink:
 
Пробвай с elseif вместо else if

да видиме дали ще даде пак грешка.
 
admin каза:
Яко ме налазиха.
Вече имам едно постче с секс линкове и 10 user-a със
секс сайтове в профила си.
Версията на форума е стара но ако почна да я ъпдейтвам ще си създам много работа.
Написах едно модче.
Незнам дали ще спаси работата но ще го постна за да пробвате и вие.
Най вероятно има готов мод за тази цел но нямам време да търся.

Проблема е, че не се генерира картинка :) ама кой му пука.
Надявам се, че ботовете са тъпички.

Ето какво направих:

Слагам тази картинка в директорията /images/ .

После oтварям файла /темплейта/profil_add_body.tpl и намирам следния код:

Код:

Преди него пиша следното:
Код:
	<tr> 
	  <td class="row1" colspan="2"><span class="gen"><center><img src="images/reg.gif"></center></span>
	  </td>
	</tr>
	<tr> 
	  <td class="row1"><span class="gen">Въведете кода: *</span><br />
		<span class="gensmall"></span></td>
	  <td class="row2"> 
		<input type="text" class="post" style="width: 200px" name="bot" size="25" maxlength="32" value="" />
	  </td>
	</tr>

После отварям файла includes/usercp_register.php и намирам следните редове (в началото):
Код:
if ( !defined('IN_PHPBB') )
{
	die("Hacking attempt");
	exit;
}

след него пиша следното:

Код:
$botstop=$HTTP_POST_VARS['bot'];

после намирам следните редове:


Код:
		else if ( strlen($new_password) > 32 )
		{
			$error = TRUE;
			$error_msg .= ( ( isset($error_msg) ) ? '<br />' : '' ) . $lang['Password_long'];
		}

под тях пиша следното:


Код:
		else if (empty ($botstop))
		{
			$error = TRUE;
			$error_msg .= ( ( isset($error_msg) ) ? '<br />' : '' ) . '<font color="ff0000"><b>Не сте въвели кода от картинката</b></font>';
		}
		else if ( $botstop != "HVAGDK" )
		{
			$error = TRUE;
			$error_msg .= ( ( isset($error_msg) ) ? '<br />' : '' ) . '<font color="ff0000"><b>Не сте въвели правилно кода от картинката</b></font>';
		}


Записвам.
При регистрацията трябва да въведе кода от картинката.
Този код не се променя ама се надявам, че няма как да разбере.



Ако някой има същия проблем може да пробва с този мод.

и се получават така две картинки...
 
админ ето тази тема на първата страница още на първия пост има хиляди начини за по-по сигурност
 
Статус
Not open for further replies.

Горе