Проблем с МySql

human

Registered
Значи като тръгна да влизам в phpmyadmin ми пише
не мога да заредя разширението mysqli,
моля проверете конфигурацията на PHP
Документация
.Като вленза в линка там пише :
[1.20] I receive the error "cannot load MySQL extension, please check PHP Configuration".
To connect to a MySQL server, PHP needs a set of MySQL functions called "MySQL extension". This extension may be part of the PHP distribution (compiled-in), otherwise it needs to be loaded dynamically. Its name is probably mysql.so or php_mysql.dll. phpMyAdmin tried to load the extension but failed.

Usually, the problem is solved by installing a software package called "PHP-MySQL" or something similar.

Какво да направя?
 

fena

Super Moderator
Дай още малко инфо, с какъв сървър си, пакет ли е накякъв...за 1ви път ли се случва, преди имало ли е подобни проблеми :wink:
 

human

Registered
fena каза:
Дай още малко инфо, с какъв сървър си, пакет ли е накякъв...за 1ви път ли се случва, преди имало ли е подобни проблеми :wink:

На моя компютър си е сървара,appserv,бях го свалял от дата.бг, но не работеше после свалях само apache(другите неща си ги имаше и мислех че работат).Това апаче разбрах вчера, че работи(преди незнаех), случайно видях от task manager-а.Когато тръгнах да влизам в phpmyadmin ми написа това.За 1-ви път пробвах вчера да го напиша и не стана.Като бях със стария компюътр(незнам с кой appserv)всичко ми работеше перфектно и mysql и phpmyadmin и apache...Мисля да си сваля нов и то да е Xamp, а не appserv
 

sizif

Registered
Здравей!

Нямам голям опит с инсталацията на сървъри, ползвам само един EasyPHР и то рядко (предпочитам да правя всичко на хоста), но с минимум усилия успях да си го инсталирам и да подкарам скриптовете, които ми вървят и на платения хост.

Защо не опиташ с най-новата версия: EasyPHP v.1.8. Пакетът е безплатен и съдържа: РНР-сървър, MySQL, PHPMyAdmin
Ето официалната страница за даунлоуд:
http://www.easyphp.org/telechargements.php3

И инструкции за инсталация на БГ. "инструкции" е силно казано, защото пакета се инсталира много, много лесно и е готов за ползване веднага.

Инструкции с графика:
http://vladi.avala.bg/old/?act=php&p=php1

Инструкции в рехав текст (напълно достатъчен) от същия автор:
http://vladi.avala.bg/?lang=bg&act=php&p=php1

И за финал, пак отбелязвам: не съм ползвал други сървъри и нямам опит в инсталации и настройки, така че ако търсиш нещо специфично, може би е по-добре да слушаш другите :)
Успех!
 

human

Registered
Мерси много, сега го свалям.Знам как се инсталира спокойно :wink: .
Ако работи ще съм много щастилив. Отново МЕРСИ!

Работи, ама в повечето случаи не се connect-ва до mysql, и не прави база данните.Аз си правя всичко ръчно :-(
 

Горе