Проблем с картинки

Radko

Registered
Не съм много сигурен, за кой раздел точно е темата, но реших за я постна тук.

За пръв път срещам подобен проблем, и ми е адски странно. Та значи имам един низ и в него съхранявам пътищата до дадени картинки. После в самия файл с цикъл изкарвам линковете от низа в img тагове. Проблема е че при първоначално зареждане на страницата не ми изкарва картинките, показва ги едва когато натисна рефреш. Проблема ми не е в кода, защото иначе въобще нямаше да ги показва колкото и да рефрешвам, странното е че при първоначалното зареждане като дам инспект на кода в барузъра img таговете са пълни, тоест като копирам src линка и го пейстна в адрес бара ми зарежда самата картинка - тоеист и линковете не са грешни.

Тествах под различни браузъри и на друг компютър - същата работа при първоначално зареждане на страницата не изкарва картинките, въпреки че в сорса си ги има като тагове с пълни линкове и прочие. Триенето на кеш също не помага.

Ако някой има идея от какво може да е, бих му бил много благодарен.
 
Както казах, не е от кода той е съвсем прост ето съответната част от него

PHP:
<?php
$arr = array('link1.jpg','link2.jpg','link3.jpg');

foreach($arr as $key => $val) {
echo '<img src="'.$val.'" />';
}
?>
 
Ами я добави в кода атрибут за height или width <img> тага на картинките. :?

Код:
<?php

$arr = array('link1.jpg','link2.jpg','link3.jpg');



foreach($arr as $key => $val) {

echo '<img src="'.$val.'" width="100" height="100" />';

}

?>
 

Горе