проблем error 500

the_end

Registered
здравейте, качих си през контролния проблем една система която беше зип архив, разархивирах фаиловете в папката и когато реших да я инсталирам на целия хост започна да ми излиза 500 Internal Server Error
изтрих системата но ефект нулев ... от какво се получава тази грешка и как мога да я оправя, имам два сайта на този хост и в момента са недостъпни въпреки че са в отделни папки в главната директория ...
моля някой да помогне да го оправя този проблем, до сега не ми се беше появявал и не знам какво да правя
 
tedo96 каза:
Защо не попиташ съпорта?

хостинга ми е в щатите и като си лафя със съпорта и направо лудвам, или адски много ги мързи тея или не знам и аз какво ... ама трябва даги моля по 10 пъти докато накрая някой се хване да направи нещо
 
от къде мога да си изтегля един стандартен .htaccess така да го кажа ... би трябвало да има такъв в който са събрани най-използваните функции валидни за повечето хостинги и системи
 
Дай си кода на .htaccess файла - стандартен .htaccess разбирам да няма нищо вътре.. не знам ти к'во разбираш под "стандартен" :D
 
ами това е че вече изтрих висчки по пакките и на тяхно място сложих празон но евекта е нулев :(
ето и съдържанието от бекъпа ... тоест какво съм изтрил

Код:
#
# Apache/PHP/Drupal settings:
#

# Protect files and directories from prying eyes.
<FilesMatch "\.(engine|inc|info|install|make|module|profile|test|po|sh|.*sql|theme|tpl(\.php)?|xtmpl|svn-base)$|^(code-style\.pl|Entries.*|Repository|Root|Tag|Template|all-wcprops|entries|format)$">
  Order allow,deny
</FilesMatch>

# Don't show directory listings for URLs which map to a directory.
Options -Indexes

# Follow symbolic links in this directory.
Options +FollowSymLinks

# Make Drupal handle any 404 errors.
ErrorDocument 404 /index.php

# Force simple error message for requests for non-existent favicon.ico.
<Files favicon.ico>
  # There is no end quote below, for compatibility with Apache 1.3.
  ErrorDocument 404 "The requested file favicon.ico was not found.
</Files>

# Set the default handler.
DirectoryIndex index.php

# Override PHP settings. More in sites/default/settings.php
# but the following cannot be changed at runtime.

# PHP 4, Apache 1.
<IfModule mod_php4.c>
  php_value magic_quotes_gpc                0
  php_value register_globals                0
  php_value session.auto_start              0
  php_value mbstring.http_input             pass
  php_value mbstring.http_output            pass
  php_value mbstring.encoding_translation   0
</IfModule>

# PHP 4, Apache 2.
<IfModule sapi_apache2.c>
  php_value magic_quotes_gpc                0
  php_value register_globals                0
  php_value session.auto_start              0
  php_value mbstring.http_input             pass
  php_value mbstring.http_output            pass
  php_value mbstring.encoding_translation   0
</IfModule>

# PHP 5, Apache 1 and 2.
<IfModule mod_php5.c>
  php_value magic_quotes_gpc                0
  php_value register_globals                0
  php_value session.auto_start              0
  php_value mbstring.http_input             pass
  php_value mbstring.http_output            pass
  php_value mbstring.encoding_translation   0
</IfModule>

# Requires mod_expires to be enabled.
<IfModule mod_expires.c>
  # Enable expirations.
  ExpiresActive On

  # Cache all files for 2 weeks after access (A).
  ExpiresDefault A1209600

  <FilesMatch \.php$>
    # Do not allow PHP scripts to be cached unless they explicitly send cache
    # headers themselves. Otherwise all scripts would have to overwrite the
    # headers set by mod_expires if they want another caching behavior. This may
    # fail if an error occurs early in the bootstrap process, and it may cause
    # problems if a non-Drupal PHP file is installed in a subdirectory.
    ExpiresActive Off
  </FilesMatch>
</IfModule>

# Various rewrite rules.
<IfModule mod_rewrite.c>
  RewriteEngine on

  # If your site can be accessed both with and without the 'www.' prefix, you
  # can use one of the following settings to redirect users to your preferred
  # URL, either WITH or WITHOUT the 'www.' prefix. Choose ONLY one option:
  #
  # To redirect all users to access the site WITH the 'www.' prefix,
  # (http://example.com/... will be redirected to http://www.example.com/...)
  # adapt and uncomment the following:
  # RewriteCond %{HTTP_HOST} ^example\.com$ [NC]
  # RewriteRule ^(.*)$ http://www.example.com/$1 [L,R=301]
  #
  # To redirect all users to access the site WITHOUT the 'www.' prefix,
  # (http://www.example.com/... will be redirected to http://example.com/...)
  # uncomment and adapt the following:
  # RewriteCond %{HTTP_HOST} ^www\.example\.com$ [NC]
  # RewriteRule ^(.*)$ http://example.com/$1 [L,R=301]

  # Modify the RewriteBase if you are using Drupal in a subdirectory or in a
  # VirtualDocumentRoot and the rewrite rules are not working properly.
  # For example if your site is at http://example.com/drupal uncomment and
  # modify the following line:
  # RewriteBase /drupal
  #
  # If your site is running in a VirtualDocumentRoot at http://example.com/,
  # uncomment the following line:
  # RewriteBase /

  # Rewrite URLs of the form 'x' to the form 'index.php?q=x'.
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteCond %{REQUEST_URI} !=/favicon.ico
  RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]
</IfModule>

# $Id$
 
Махни това:

Код:
# PHP 4, Apache 1.
<IfModule mod_php4.c>
  php_value magic_quotes_gpc                0
  php_value register_globals                0
  php_value session.auto_start              0
  php_value mbstring.http_input             pass
  php_value mbstring.http_output            pass
  php_value mbstring.encoding_translation   0
</IfModule>

# PHP 4, Apache 2.
<IfModule sapi_apache2.c>
  php_value magic_quotes_gpc                0
  php_value register_globals                0
  php_value session.auto_start              0
  php_value mbstring.http_input             pass
  php_value mbstring.http_output            pass
  php_value mbstring.encoding_translation   0
</IfModule>

# PHP 5, Apache 1 and 2.
<IfModule mod_php5.c>
  php_value magic_quotes_gpc                0
  php_value register_globals                0
  php_value session.auto_start              0
  php_value mbstring.http_input             pass
  php_value mbstring.http_output            pass
  php_value mbstring.encoding_translation   0
</IfModule>

И пробвай пак.
 
нищо не се случва ..... :(
успях да разбера че проблема идва след /www/
в смисал всяка папка с фаилоте дори и един обикновен индекст с надпис здрасти не работи
когато го сложа в главната директория работи но в папка /www/test/
ми излиза error 500
изтрих всички файлове от сървара и всички домейни и субдомейни и файда 0
съпорта направо бих го взривил само да разбера къде се помещават ... такива балъци няма
 
ето какво ми излиза в ерор лога от цпанела
Код:
[Thu Feb 23 03:26:39 2012] [error] [client IP] client denied by server configuration: /home/host/public_html/.htaccess

[Thu Feb 23 03:18:16 2012] [error] [client IP] File does not exist: /home/host/public_html/404.shtml, referer: http://host.me/

[Thu Feb 23 03:18:16 2012] [error] [client IP] File does not exist: /home/host/public_html/favicon.ico, referer: http://host.me/

качих празни файлове
.htaccess
404.shtml
500.shtml
и favicon.ico

ефект отново нула
 
relax4o каза:
Я изтрий всичко под # Various rewrite rules.

а може ли да ми разясниш малко какво значи това и как точно да го направя ... чувам го за първи път
 
the_end каза:
relax4o каза:
Я изтрий всичко под # Various rewrite rules.

а може ли да ми разясниш малко какво значи това и как точно да го направя ... чувам го за първи път


:shock: :shock: :shock: :shock: :shock: :shock: :shock: :shock:



Имам предвид това:

PHP:
# Various rewrite rules.
<IfModule mod_rewrite.c>
  RewriteEngine on

  # If your site can be accessed both with and without the 'www.' prefix, you
  # can use one of the following settings to redirect users to your preferred
  # URL, either WITH or WITHOUT the 'www.' prefix. Choose ONLY one option:
  #
  # To redirect all users to access the site WITH the 'www.' prefix,
  # (http://example.com/... will be redirected to http://www.example.com/...)
  # adapt and uncomment the following:
  # RewriteCond %{HTTP_HOST} ^example\.com$ [NC]
  # RewriteRule ^(.*)$ http://www.example.com/$1 [L,R=301]
  #
  # To redirect all users to access the site WITHOUT the 'www.' prefix,
  # (http://www.example.com/... will be redirected to http://example.com/...)
  # uncomment and adapt the following:
  # RewriteCond %{HTTP_HOST} ^www\.example\.com$ [NC]
  # RewriteRule ^(.*)$ http://example.com/$1 [L,R=301]

  # Modify the RewriteBase if you are using Drupal in a subdirectory or in a
  # VirtualDocumentRoot and the rewrite rules are not working properly.
  # For example if your site is at http://example.com/drupal uncomment and
  # modify the following line:
  # RewriteBase /drupal
  #
  # If your site is running in a VirtualDocumentRoot at http://example.com/,
  # uncomment the following line:
  # RewriteBase /

  # Rewrite URLs of the form 'x' to the form 'index.php?q=x'.
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteCond %{REQUEST_URI} !=/favicon.ico
  RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]
</IfModule>
 
ами бутнах го това в празния .htaccess и го качах в главната директория ... не виждам разлика
 
ами в момента на хоста има само и единствено coming soon page
и ново 20 ... ако индекса е .php ми излиза ерор 500 ако е .html ми се появява съдържанието на индекса
 
Направи си backup и изтрий всички файлове - виж дали ще ти излиза тая грешка, ако ти не излиза провери къде имаш .htaccess и ги "изпразни", ако грешката продължава провери правата на папките и файловете - но тогава би трябвало да ти излезе 403 грешка, както и да е провери ги.

В противен случай пиши на Support-а
 
всичко което описа съм го направил ... бекъп на всички файлове, изтрих всико от хоста и качих един индекс с поздравително съобщение ... докато беше с разширение .php не работеше а когато го направих с разширение .html тръгна .. то в самия файл е само html ... съпорта е пълна скръп 4 дена вече нищо не направиха ...
 
Така, както описваш проблема и тия ако не ти отговарят направо сменявай хоста.

Не виждам дали би имало ефект, щом не чете .php файлове , но я пробвай;

<?php
phpinfo();
?>

500 Internal Error - често се получава когато има грешка в някой CGI скрипт, от друга страна това си е сървърна грешка.

ЕДИТ: Можеш да настроиш различни параметри на PHP през .htaccess файловете. Това се прави с php_value и php_flag, първата ти е за настройка изискваща число или стринг, втората е да включва/изключваш да дена функкция..

Коя версия ти е PHP-то и коя версия ти е Apache сървъра?
 
най-накрая след 20 писаници със съпорта решиха да откликнат на молбата ми още от първите съобщения да рестартират акаунта ... крайно време беше ... 4 дена мъки ... благодаря на всички :lol:
 

Горе